Incident impacting Phishing & Awareness Training

Minor incident Security Center (Europe, Sweden)
2021-11-08 11:27 UTC · 2 days, 8 hours, 13 minutes

Updates

Resolved

This issue has been resolved.

November 10, 2021 · 19:40 UTC
Issue

We are experiencing an issue with duplicated email being sent out for Phising & Awareness Training. Engineers have isolated the issue and a fix for it is planned for tomorrow 10th Nov.

November 9, 2021 · 11:29 UTC

← Back