Incident impacting Phishing & Awareness Training

Major incident Security Center (Europe, Sweden)
2021-10-07 20:06 UTC · 16 hours, 31 minutes

Updates

Resolved

This incident has been resolved.

November 4, 2021 · 15:25 UTC
Investigating

We are currently investigating an issue with Phishing & Awareness Training that is impacting the performance of displaying Assessment result overview for new assessments.

November 4, 2021 · 15:25 UTC

← Back