Email incident

Major incident Security Center (Europe, Sweden)
2020-09-23 19:33 UTC · 25 minutes, 18 seconds

Updates

Resolved

The issue has been mitigated and emails are being handled normally again. Cause of incident is still being investigated.

We urge impacted recipients to contact support@holmsecurity.com for further information regarding this matter.

September 23, 2020 · 19:58 UTC
Issue

FRA notifications have been sending out massive amount of emails. Engineers are shutting down the service temporarily and are investigating the issue.

September 23, 2020 · 19:36 UTC

← Back