Incident impacting Remediation
Minor incident
Security Center (Europe, Sweden)
2025-10-08 12:35 UTC
· 4 days, 18 hours, 14 minutes
Updates
Resolved
October 13, 2025 · 06:49 UTC
The incident has been resolved and the remaining tickets have been updated over the weekend.
We continue to monitor the situation, but don’t expect any further issues.
Issue
October 8, 2025 · 12:35 UTC
We are currently investigating an issue with Remediation that is impacting the time it takes for tickets to be updated or created.
This incident will receive continuous updates as we make progress on our investigation.
For any urgent matters, contact support@holmsecurity.com.
← Back